Email Delivery Disruption
Resolved·Full outage

The incident is resolved now, in product email delivery is back to normal.

Fri, Aug 1, 2025, 11:31 AM
(1 month ago)
·
Affected components
Email Delivery
Updates

Resolved

The incident is resolved now, in product email delivery is back to normal.

Fri, Aug 1, 2025, 11:31 AM

Identified

We’re currently experiencing issues with email delivery across our platform. Most product-related emails (such as invites and notifications) are not being sent.

Wed, Jul 30, 2025, 07:07 PM(1 day earlier)