Resolved
Sign-ups are functional again. Thank you for your patience.
Investigating
We are currently experiencing issues with our sign-up service. New account registrations are temporarily disabled while we work to resolve this. Existing users are not affected. We apologize for the inconvenience and will provide an update shortly.