Resolved
This incident has been resolved.
Monitoring
A fix has been implemented and we are monitoring the results.
Investigating
Our external service used for Asset handling is currently experiencing issues. Mainly asset transformation, as well as uploads are affected by it. Our team is investigating.