Resolved
This incident has been resolved.
Monitoring
Upon investigation, a general slowdown in request times was caused by a large number of long-running queries. Affected queries have been cleaned up, we will continue monitoring the issue.
Investigating
We're experiencing elevated response times for the Management API and are currently looking into the issue. The same issue is affecting the UI currently.